Peyronies Society Forums

Please login or register.

Login with username, password and session length
Pages: [1]   Go Down

Author Topic: ever seen blood after pump use?  (Read 2210 times)

0 Members and 1 Guest are viewing this topic.

BillNMS

  • Voting Member
  • **
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 9
ever seen blood after pump use?
« on: September 20, 2014, 06:40:56 PM »

If I have already posted this, I can not find it, so sorry if I have! But I have been using a pump with great results for general rehab for these months after having RP. I can not tell that I have any post surgery shrinkage at all, so that is good so far considering no erections. I have been experimenting with ring use for sex, and I find that I need 2 rings to maintain an erection for enough time or if I lay down.

I am careful not to cause any pain when pumping, don't want to hurt anything. But, it is an experiment where I am having to back off of maximum pain free pump because after I put both rings it actually seems too dang hard, hard as that is to believe.

So the other day, even though I backed off on the amount of pump pressure, it still seemed too hard with the two rings, so I stretched them with my fingers for a few seconds to let some blood out. So it seemed OK, but when I removed the rings after orgasm, a fair amount of blood came out with the urine!  :-\ I got blood all over the floor and such, but it seemed to mostly stop pretty quick. A few hours later I still had a few drops of blood with urination, then saw no more after a few hours more, and none since, maybe 1 1/2 weeks.

So, anyway, any thoughts? Any one ever had any blood when pumping or during sex helped with a VED? This was with an Augusta Soma Response 2 pump and one size largest (Z) Surefit ring plus one size Y(medium). No blood since then, but I have only pumped for rehab once, with no rings, feeling a bit cautious about it all.
Bill
Logged

james1947

  • Major Contributor
  • ****
  • Country: ro
  • Offline Offline
  • Gender: Male
  • Posts: 6339
  • Age 69. Peyronies from January 2009
Re: ever seen blood after pump use?
« Reply #1 on: September 20, 2014, 07:44:26 PM »

Bill

The only thing I can say is that you should see an urologist. I never encounter such thing and didn't read about on the forum also.

James
Logged

Old Man

  • Senior Member - Major Contributor
  • *****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 2127
Re: ever seen blood after pump use?
« Reply #2 on: September 20, 2014, 09:05:24 PM »

BillNMS:

Your post is a bit confusing for me to understand exactly whether or not you used the rings first and then pumped up the pressure.

If you did, THIS IS A NO NO!

Edit: The above original post was accidently posted before completing my comments.

Bill: If you ARE placing the cock rings on your shaft and then pumping up, you should stop doing this immediately. Further damage can and will be caused by doing this procedure. The rings should be placed on your penis only after pumping to a comfortable level and only when you intend to go for sexual activity!

My experience with working with guys in their Peyronies Disease VED therapy has revealed that several have placed the rings onto their shaft first and then start using the Peyronies Disease therapy pump up schedule. They caused considerable damage to an already damaged penis.

So, guys remember that the above caution is stated for your information and safety when using VED therapy.

Old Man

Logged

BillNMS

  • Voting Member
  • **
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 9
Re: ever seen blood after pump use?
« Reply #3 on: September 21, 2014, 04:23:10 PM »

Thx for the replies, guys!

James, I will certainly see my urologist if it happens again. I go for a follow up with my surgeon in October anyway, and will bring it up with him. But no further sign of any blood in 10 days, including simply doing the a rehab pump with no rings, and having an orgasm after injection, again no rings. Still, I understand it is a concern. I was hoping it had happened to others, but apparently not, and that does make it a bit worrisome. I am 7 months out from my prostate surgery or RRP.

Old Man: Sorry for the confusion! I have always pumped up at least a fair amount before applying rings. To clarify: 1 ring applied after pumping up often will not keep me hard for more than a very few minutes. 2 rings seems to do much better. But 2 rings often seem to go too far. When I remove the pump, the erection is like steel, plenty usable for sex but really a bit much. A bit uncomfortable and a bit scary. For some reason it actually seems harder than before I applied the rings and removed the pump.

As this has happened a few times now, I have been experimenting with letting off on the amount of pump a bit before applying 2 rings. Still plenty firm, but not the max I can reach in the pump before discomfort.

The day the bleeding happened, I backed off a bit on the amount of pump negative pressure, applied the 2 rings, removed the pump, but felt it was still a bit too hard. So working my fingers under the rings, to stretch them for just a second to let the erection die down a tad. The put them back on. Right now I am having trouble remembering: I might even have removed one of the rings. Any way, I went on to orgasm, removed the ring/rings, and saw the blood. I have not seen any since. I hope this is clearer.

My suspicion is that the "too danged hard" situation caused by the 2 rings caused too much pressure on a blood vessel during orgasm. I'm hoping that is all it was. But even if it was, I've got to find a solution to having enough tension from the rings to keep things hard enough for action, but not so tight as to burst a vessel! ( again, if that is actually the cause of the problem and not something more serious)

Thx again Guys!

Bill
Logged

Old Man

  • Senior Member - Major Contributor
  • *****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 2127
Re: ever seen blood after pump use?
« Reply #4 on: September 21, 2014, 04:54:55 PM »

BillNMS:

Ok, that explains it bit better for me. As I said, do not place the restriction rings before starting a Peyronies Disease pump up session, nor at any time you are not going for a sexual erection. Remember that less pressure with doing the Peyronies Disease therapy is much better than more pressure. You simply want to ''exercise'' the penile tissue in the corpora to help with eliminating the nodules, hour glass effect and in general provide a more healthier penis.

Since you are having problems with arriving at the proper tension ring for yourself, I would like to suggest another type and style tension ring that will definitely prevent the bleeding problem if it was caused by a ring or rings that were too tight. I will send the web source and ordering information to you by a PM.

Sorry to question your procedure, but just wanted to make sure that you were not pumping up with the restriction rings in place beforehand.

Old Man
Logged

BillNMS

  • Voting Member
  • **
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 9
Re: ever seen blood after pump use?
« Reply #5 on: September 21, 2014, 05:29:18 PM »

No problem at all, Old Man, better safe than sorry! I will look into that info you are sending!

I should add one more fact or impression anyway just to provide all info possible:

My impression is that the bleeding came from the urethra rather than the bladder, if that might make any difference. Here's why:
1: I felt a pretty big pressure building up - I think more than in the past- right behind the rings during blast off, as though something was trying hard to get out but couldn't. This might can not be semen in my case of course, but was probably urine. But anyway, it felt like quite a bit of pressure in the base of my penis, which of course has the urethra in the center of it, and urine trying to escape would have been trying to escape the usual route: the urethra.
2: when I took the rings off, and urinated, blood came out with the urine. I had urinated just before starting, but it seems like there is always quickly some more available, no matter if I pi$$ a quart right before hand.
3: right after I finished urinating, plain old undiluted blood came running out for a minute or so. No urine was mixed with this blood.
4: Later on in the day, I saw no more blood except very diluted visible in the last few drops of urine. I think if I had been bleeding as much into my bladder as what I saw right after taking the rings off, I would have had at least darkened urine for the rest of the day.

But I am just guessing at this point. But my guess is that I popped a little vessel either from too much tension from 2 rings, or from the pressure of urine(most likely) trying to get past the rings as in days of old with semen and ejaculation. That's my guess at this point.

But, I am pretty cautious and I back off of anything at the first sign of discomfort. So I am surprised that there is not at least 1 gung ho guy out there that has seen some blood. Someone who was pumping for maximum size and using max ring tension, especially a younger or non-surgery guy who still has some semen to push out. But if they are there they might not have seen this thread. Plus, I suppose I could still have some tender vessels in there somewhere even 7 months past surgery.
Bill
Logged

Old Man

  • Senior Member - Major Contributor
  • *****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 2127
Re: ever seen blood after pump use?
« Reply #6 on: September 21, 2014, 05:38:53 PM »

BillNMS:

You have not mentioned that you sought medical attention for the bleeding problem, so just as a precautionary measure, you should seek professional help too. Remember, I am not a doctor of any sort, just an 85 year old goat who has been around the medical world for a very long time.

IOW, as far as  men's sexual health problems, I have ''been around the horn'' as the expression goes. My medical history now fills several medical records CDs!

Glad to be of help at any time. 

Old Man
Logged

BillNMS

  • Voting Member
  • **
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 9
Re: ever seen blood after pump use?
« Reply #7 on: September 21, 2014, 05:54:23 PM »

I do want to add: despite this one mishap so far, I think the pump has provided for some useful rehab. When the catheter first came out after surgery, I felt that I was definitely already starting to suffer from shrinkage, as I have read about from more than one man. I guess it can still happen later, especially if I stop doing any rehab, but so far I have not suffered any shrinkage. It didn't take long after I started using it to get back to normal. I would say that for several months now I have been at least at full pre-surgery erect length, and if anything I have a tiny bit more girth and def more flaccid hang, not less. So I am very happy with that aspect of pump use. Using it for sex, though, is still a work in progress!
Bill
Logged
Pages: [1]   Go Up
 

Related Topics

  Subject / Started by Replies Last post
6 Replies
1481 Views
Last post January 02, 2013, 11:46:51 PM
by DO
2 Replies
3026 Views
Last post June 19, 2013, 06:31:35 AM
by whosethedaddy
2 Replies
968 Views
Last post March 01, 2015, 05:19:56 PM
by Jonbinspain